
Guide to producing species distribution maps using the ZSL CTAP and QGIS 

 

Installing QGIS 

Run the QGIS executable setup file ‘QGIS-OSGeo4W-2.18.2-1-Setup-x86_64.exe’, and follow the on-

screen prompts in the installer. For the following exercise, only the basic QGIS package is required 

with none of the optional example datasets included in the software installation. 

  

Exporting and formatting data from ZSL CTAP for mapping in QGIS 

Organising data 

The first step is to setup folders to store all of the spatial data files and data exported from the ZSL 

CTAP program, as this involves multiple files and can become disorganised very quickly. The file 

structure as demonstrated below is the best way to keep the spatial data files (shape and raster 

files) and CTAP data organised and easily accessible.  

 

 

 

 

 

 

 

Exporting camera location data from CTAP 

The file format used by QGIS to read spatial ‘numerical’ data is comma separated “.csv”. Therefore, 

any data to be imported into QGIS needs to be exported from CTAP in this format.  

To export survey camera locations open the ‘Camera Stations’ tab for the selected survey and right 

mouse click on the table and select ‘Save Table As -> Comma-Separated Text File (*.csv) as shown 

below.  Save this file into the ‘Functional and failed camera locations’ folder created in the previous 

step. In this example it is called ‘Camera Trap Stations Cynometra.csv’. 

 

Note: In this example the main folder name is the site name where 

the camera trap survey was carried out. The four subfolders will 

enable proper organisation of your data and resulting maps. 



 
 

Formatting camera trap location data before importing into QGIS 

The exported .csv file then needs to be opened in EXCEL and formatted prior to importing into QGIS. 

All columns except the ‘Actual – Latitude and Longitude’ and ‘Label’ columns need to be deleted as 

shown below. Any failed cameras then need to be removed and placed in a separate ‘Failed 

cameras.csv’ file in the ‘Functional and failed camera locations’ folder. The functional cameras data 

file can then be saved as with name ‘Functional cameras.csv’ also in the ‘Functional and failed 

camera locations’ folder.  

  
 

 

 

Note: Any camera traps considered to have failed needs to be removed from this file and placed 

in a separate ‘Failed cameras.csv’ file. 



Exporting species trapping rates 

Species trapping rates at each camera station can be obtained from the following location in CTAP 

program ‘Analysis and Reports->Species/Taxa->Distribution->Table’. Each species that a distribution 

map is going to be produced needs to have it’s own trapping rate csv file saved in the ‘Species 

trapping rates’ folder. The data export step is the same as that performed for the camera locations, 

by right clicking and selecting ‘Save Table As > Comma-Separated Text File (*csv)..’. 

 
 

Formatting species trapping rates for import into QGIS 

Next the species trapping rate csv files need to be formatted before importing into QGIS. As we want 

to plot the trapping rate at each camera station, the first step is to remove any unnecessary data as 

shown below. We will be plotting the untransformed ‘linear’ trapping rate.  

 

  
 

Note: Make sure to select the 

appropriate species before 

exporting the data.  

 

Note: The data are displayed in 

a chart by default. To change 

to the ‘table’ view click the 

‘Table’ tab.  

 



The daily trapping rate then needs to be converted into number of event per 100 days, by 

multiplying the daily trapping rate by 100. The trapping rate per 100 days then needs to be rounded 

to a whole number. Camera traps with trapping rate zero need to be removed (highlighted in blue). 

Scaling points (highlighted yellow) are required to ensure that all species distribution maps are 

porpotional to one another. These values are established once all of the trapping rates for each 

species has been exported, as the maximum scale point is the largest recorded trapping rate of all of 

the species for which distribution maps are to be produced. The minimum is always one to allow 

QGIS to correctly scale the points relative to one another.  

 

 

 

 

  
 

 

 

 

 

 

The edited .csv file should be saved as the species name in the ‘Species trapping rates’ folder, 

replacing the original export file from the tool. This process needs to be repeated for all species for 

which distribution maps to be produced. 

Setting up a project in QGIS 

Open ‘QGIS Desktop 2.18.x’ and select ‘Project’->’New’ to begin a new project. Then select ‘Project’-

>’Save as’, and save the project to the folder created in the beginning of this tutorial. In this example 

the project will be saved to the ‘Arabuko-Sokoke maps’ folder and saved as ‘Arabuko-Sokoke forest’. 

 

Note: In this example the larger scaling point is 

the same as the highest value. As the maps 

aren’t being produced for multiple species. 

However, if the highest trapping rate for 

another species detected in this survey was 68, 

the larger scaling point would be 68 

Note: The northing and eastings 

have all been set to 1 for the scale 

points, to ensure they don’t appear 

on the exported map. 

 

Note: trapping rate per 100 days 

is calculated in this cell using 

=D2*100, and is then rounded 

using =ROUND(E2,0) in the F 

column.  

 

Note: This is how the .csv file 

should look once the steps 

above have been followed. It 

is now ready for import into 

QGIS.  

 



 

 
 

Importing and displaying shape files 

Vector and raster files are used to display features as layers on the map in QGIS. Vector files ‘ESRI 

Shape’ files consist of points, lines and polygons which are geospatially referenced. In the case of 

Arabuko-Sokoke forest we will use the following shape files; Vegetation type, trails around the forest 

and the protected area boundary. These shape files can be found in the ‘shape files’ folder (Arabuko-

Sokoke forest> Shape files>Features).  

Shape files can be imported by selecting Layer>Add Layer>Add Vector Layer. This will bring up a 

console to import the layer, select browse and choose the required .shp file in this example; 

Arabuko-Sokoke forest> Shape files>Features>Vegetation cover.shp. Click ‘Open’ to add the selected 

shape file to the current project.  



 
 

The previous steps are repeated for both the ‘Protected area’ and ‘Trails’ shape files to add them to 

the project. 

By double clicking on a layer in the ‘Layers Panel’, the ‘Layer properties’ console for that layer will be 

opened. This allows you to view and edit a range of information for the selected layer. To view the 

attribute table right click the layer in the ‘Layers Panel’ window and select ‘Open Attribute Table’.  

 

 

 

 

Note: This is how the map will look once all three shape files have been 

added. 

Note: You can drag the layer up / 

down to alter the order in which 

layers are displayed. 

Note: Individual layers 

can be hidden or 

displayed by checking 

and unchecking this box. 

Note: The information regarding the 

vegetation types is contained in the 

‘VEG_TYPE’ column.  

 



Vegetation cover will be used for this example to change how the vector data symbology is 

displayed. Double click on the Vegetation cover layer and then select the drop down menu at the 

top of the ‘Layer properties’ console under the ‘style’ tab. This will give a range of options for 

vegetation type: select ‘categorized’. This will render the vector data by displaying different colours 

for each value of a selected field.  

 

To get QGIS to display the vegetation types in different colours, select the ‘VEG_TYPE’ from the 

‘column’ drop down menu, as the attribute table for the shape file indicated the relevant data was 

contained in that column.  

 

 
 

Note: The drop down menu to 

control how data are displayed in 

a layer is located here.  

 



 
 

Once the correct attribute has been selected from the ‘Column’ drop down menu click the ‘Classify’ 

button. This will classify the data selected in the ‘Column’ drop down menu. To change the fill and 

outline of each category, double click on the symbol of the category to be modified in the ‘Symbol’ 

column. This will bring up the ‘Symbol selector’ console. Then select the ‘Simple fill’ option to alter 

the features of how the category will be displayed. Select appropriate colours for the different 

vegetation types. 

 

 

 

 

 

 

 

 

 

 

In this example for the ‘Protected area’ and ‘Trails’ layers ‘Single Symbol’ (default) is selected from 

the drop down menu at the top of the ‘Layer Properties’ console, which means that a single style is 

applied. The fill for the ‘Protected area’ layer is set to ‘transparent fill’ and outline to 1mm. The 

‘Trails’ layer needs to have the line colour changed to brown and the width set to 0.5. The image 

Note: Each feature within a category 

can be edited within the drop down 

menus in the ‘Simple fill’ option. The 

outline width is in millimetres by 

default and is typed in.  

Note: The symbol next 

to each category needs 

to be double clicked to 

bring up the ‘Symbol 

selector’ console. 

Note: The ‘Column’ drop down 

menu controls which attribute from 

the attribute table is displayed in 

the current layer. 

 



below shows what the map should look like after the steps above have been followed. The map is 

now ready to have the camera trap location layer added.  

 

 
 

Saving shape files 

Shape files and their formatting can be exported and saved, t allowing backups of shape files to be 

created and sent to other QGIS users. This is done by right clicking the layer to be saved in the 

‘Layers Panel’ and selecting ‘Save As Layer Definition file…’. This brings up a dialogue box where the 

location that the shape file should be saved needs to be selected and the shape file named. Once 

this has been completed click ‘Save’, QGIS will then export the layer to the selected location. In this 

example all shape files have been saved to Arabuko-Sokoke maps>Shape files.  

Importing and displaying camera trap locations 

Camera trap locations are imported from the .csv file created earlier; by choosing Layer>Add 

Layer>Add Delimited Text Layer, then using the ‘Browse’ button and selecting the relevant file. In 

this example Arabuko-Sokoke maps>Camera locations>Functional cameras.csv.  

 

If the file is formatted correctly QGIS should automatically detect the northings and eastings 

headings and place them in the correct field. Press ‘OK’ to bring up the ‘Co-ordinate Reference 

System Selector’ console. This will be the same as the co-ordinate reference system used to import 

the data into the tool. In this example UTM was used and the zone the survey was conducted in was 

Note: The ‘Protected 

area’ layer is below 

the ‘Vegetation type’ 

layer. This ensures the 

boundary is displayed 

correctly. 

 



37S so the ‘WGS 84 / UTM Zone 37S’ option is selected.  

 

 

 

Note: QGIS has automatically placed 

the northings and eastings in the 

correct fields, and the first record 

has field names box has been 

checked. 

 



The functional cameras layer should be moved to the top of the layer list to display the camera 

locations. The layer should then be edited in the same way as the other shape files that were 

imported previously, using ‘Single symbol’ format for appropriate size and colour.  

 

 

 

 

 

 

 

 

 

 

 

 

 
 

Note: The full list of co-ordinate 

reference systems available is displayed 

and the selected system is displayed 

below. 

Note: In this example the outline 

width has been increased from 

hairline to 0.4mm 

Note: A preview of the camera trap 

symbol is available as edits to the layer 

are made. 

The functional cameras 

layer should be moved 

to the top of the layer 

list to display the 

camera locations. The 

layer can then be 

edited using ‘Single 

symbol’ format for 

appropriate size and 

colour.  

 



Importing and scaling species trapping rates 

Species trapping rates are imported into QGIS using the same process as camera trap locations. By 

choosing Layer>Add Layer>Add Delimited Text Layer, then using the ‘Browse’ button selecting the 

relevant file. In this example Arabuko-Sokoke maps>Species trapping rates>Golden rumped 

sengi.csv. As the correct co-ordinate reference system was used to import the camera trap locations 

QGIS will automatically choose WGS 84/ UTM 37S.  

The species trapping rates layer then needs to be edited to display the trapping rate per 100 days at 

each camera trap location proportional to one another. To do this ‘Graduated’ rendering of the 

vector data is required, this will display the symbols proportionally to one another based on the 

selected attribute. Select the ‘Graduated’ option from the top bar of the ‘Layer Properties’ console. 

Having viewed the attribute table for the ‘Golden-rumped sengi’ layer, to display the trapping rate 

per 100 days at each camera the ‘Events / 100 days’ column needs to be selected in the ‘column’ 

drop down menu.  To display the symbols as different sizes rather than colours, ‘Size’ needs to be 

selected from the ‘Method’ drop menu. The size of the smallest and largest symbols can then be 

specified in the relevant fields (NB it is important the size of the smallest trapping rate is larger than 

the camera trap locations symbol, to ensure it is totally covered when the species is present at a 

location). The appearance of each symbol can be edited in the same way as other layers by clicking 

the ‘Change…’ button, which will bring up the ‘Symbol selector’ console.  

 

 
 

The final step in formatting how the trapping rates at each camera trap location are displayed is to 

scale the symbols relative to one another. This is achieved by setting the ‘Mode’ to ‘Pretty Breaks’ 

and the number of classes in the ‘Classes’ option to the large scaling point value minus one to have 

in this example 42 classes (1-2, … 42-43). This allocates each increase of trapping rate per 100 days 

by one its’ own specific size class. Click ‘Classify’ and confirm that the classification has occurred 

correctly. ‘OK’ can then be clicked to complete the changes to the selected layer.  This layer can then 

be saved as the name of the species in the relevant folder.  

 



 
 

The images below demonstrate how the species trapping rate layer will appearance in QGIS after 

following the steps outlined above. As camera stations with zero trapping rates values were 

removed from the data prior to import, the camera trap location symbol in the layer below the 

species trapping rate layer is visible when the species was not detected at a camera trap. This 

process needs to be repeated for all species that require distribution maps. Once this is complete 

the maps are now ready to be exported.  

 

 

 

 

 

 

 



 
 

Publishing and exporting maps 

To begin publishing a map, a new ‘Print Composer’ needs to be created by clicking Project>New Print 

Composer. This will bring up a dialogue box where the print composer needs to be given a title; in 

this example it is called ‘Arabuko-Sokoke species distribution maps’. 

 

Note: The species 

trapping rate layer 

needs to be placed 

above all other layers 

to be displayed 

correctly on the map. 

By either clicking and 

dragging them above 

other layers or using 

the arrows in the 

‘Layers panel’. 

 



 
 

This will then generate a new print composer. There are four key functions used to publish maps for 

export: ‘Add new map’, ‘Add new legend’, ‘Add new scale bar’ and ‘Add image’. These are 

highlighted in the image below 

 

Initiating 

publishing and 

exporting maps 

through New 

Print Composer  



 
. 

The first step is to zoom and position the map in the main project window as you would like to 

appear in the print composer and also selecting the appropriate ‘Species distribution’ layer. Next add 

the map by clicking on the Add new map icon. This will bring up a cursor, click and drag from the top 

left corner to the bottom right of the white area so the red box covers the perimeter and release the 

click. This will import the map into the composer. 

 

 
 

Add image 

Add new legend 

Add new map 

Add new scale bar 

Note: All of the 

items that are 

added into the map 

composer are 

edited from within 

the ‘Item 

properties’ console. 

 

Note: The order 

items appear in 

maps to be 

exported is 

controlled by 

dragging them up 

and down the list 

in the ‘Items’ 

window.  

 



To add a legend to the map in the composer click the ‘Add new legend’ icon and click and drag a 

rectangle of the approximate size of the desired legend. The properties of the legend are edited the 

‘Item properties’ console.  

 

The Legend title can be changed, in this case left blank as the species name is in the layer name.   

Within the ‘legend items’ sub-section ‘Auto update’ should be unchecked; this allows the manual 

manipulation of the symbols and their properties displayed in the legend. All species other than the 

one having a map currently being produced need to be removed by highlighting the species and 

deleted using the red minus button at the bottom. The individual symbols to be displayed for each 

species can be displayed and edited by pressing the ‘plus’ button next to the layer file. In this 

example, we only want to display 1 event / 100 camera trap days and 10 events / 100 camera trap 

days. The other symbols should be removed using the same method as above, by highlighting and 

pressing the red ‘minus’ button. The labels for each item in the legend are edited by double clicking 

the text which will bring up the ‘Item text’ editing console. The labels of each layer can be removed 

from the legend by deleting the text in the ‘Item text’ editing console and clicking ‘OK’. 

Within the ‘Item properties’ console the font, size and height of categorised symbols, spacing 

between items, frame and background of the legend can all be edited within their respective sub-

menus.  

Once all these have been edited to the style desired, the legend can be positioned on the map by 

dragging and dropping it or using the arrows on the keyboard.  

 

 
 

A scale bar is added by clicking the ‘Add new scale bar’ button, and dragging a box using the cursor 

the approximate size of the required scale bar. Again the features of the scale bar can be edited in 

the ‘Item properties’ console including font, background and scale. The units displayed can be 

selected within the units sub-menu; in this example kilometres is used which is the default setting 

Note: by scrolling down 

using this bar other options 

in the sub menu such as 

font can be accessed. 

Note: The labels of the 

layers have been removed 

by double clicking the title 

and removing it in the 

‘Item text’ editing console.  

 

 

Note: The red minus button for removing items 

from the legend. Multiple items can be selected 

by clicking the first to be deleted holding shift 

and selecting the final item to be deleted. The 

items in-between these will now be highlighted. 

 

Note: The categories 

that are displayed in a 

layer can be shown and 

hidden by clicking this 

button. 

 



for UTM. Once edited, the scale bar can be positioned beneath the legend by dragging using the 

mouse and fine-tuned using the key board arrows. The width and height of the scale bar background 

can be edited by clicking on the bar and dragging it using the white boxes that appear around it’s 

perimeter.   

 

 
 

To add a North arrow to the map click the ‘Add image’ button to bring up the ‘Search directories’ 

sub-menu. Within the ‘Search directories’ sub-menu press the ‘Add’ button to load the default 

images provided by QGIS. Select the desired North arrow and drag the cursor to draw the size of 

North arrow that is required. This will then be inserted into the composer; the fill and size of the 

arrow can be edited in the same way as the other items previously imported into the composer.  

 

Note: By increasing the right value the number of 

segments in the scale bar is increased by the order 

dictated in the units below. 

In this example for every increase of the right value, 

the scale bar will increase by 2km. If units was set 

to 3000 it would increase by 3km and so on.  

 

Note: The white boxes around the perimeter that 

allows the size of the background of the scale bar to 

be manipulated.  

 



Note: The type of image 

file the map is to be 

exported as can be 

selected from this drop 

down menu,which is 

opened after selecting 

‘Export as image…..’ 

 

 
 

Once the map has been checked it is now ready to be exported and saved. This is done by clicking 

‘Composer>Export as Image….’. This will open a dialogue where the location the map is to be 

exported to is chosen. In this example it will be saved in ‘Arabuko-Sokoke species maps>Golden-

rumped sengi.jpg.’ The resolution, page height and page width of the map can be altered in the 

‘image export options’ console, once the settings have been confirmed click ‘OK’ to export the map.  

 

 



 
 

The above process needs to be repeated for every map that is going to be produced. The image 

below is the final map exported from QGIS using the steps outlined above. 

 

 
 


